paint-brush
Cómo ejecutar varias versiones de Flutter en macOSpor@altynberg
8,826 lecturas
8,826 lecturas

Cómo ejecutar varias versiones de Flutter en macOS

por Altynbek Usenbekov2m2021/06/17
Read on Terminal Reader
Read this story w/o Javascript
tldt arrow
ES

Demasiado Largo; Para Leer

A veces necesitamos tener múltiples versiones de Flutter en la misma máquina para diferentes proyectos. Para hacer esto, debemos descargar varias versiones y agregar esas rutas al archivo bash_profile y nuestro IDE. Usaré macOS y Visual Studio Code para crear las rutas. Cada proyecto puede usar una versión específica de Flutter para diferentes propósitos. Como resultado, tenemos dos versiones diferentes de la misma versión del software. Las rutas deberían dar versiones diferentes por diferentes razones. Por ejemplo, tengo dos versiones en dos rutas diferentes: Flutter_stable/bin/flutter/bin.

Company Mentioned

Mention Thumbnail
featured image - Cómo ejecutar varias versiones de Flutter en macOS
Altynbek Usenbekov HackerNoon profile picture

A veces necesitamos tener múltiples versiones de Flutter en la misma máquina para diferentes proyectos. Para hacer esto, debemos descargar varias versiones y agregar esas rutas al archivo bash_profile y nuestro IDE. Usaré macOS y Visual Studio Code.

Supongo que Flutter ya está instalado. Así que ya deberíamos tener una carpeta Flutter SDK. Descarguemos una versión diferente de Flutter y colóquela en la misma carpeta que la carpeta SDK actual.

En mi caso, por defecto tenía una versión anterior de Flutter. Además de eso, descargué el canal estable y lo renombré.

 flutter_stable
. Ahora tengo dos versiones en dos caminos diferentes:

A continuación, duplicamos el

 flutter_stable/bin/
 flutter
archivo y cambiarle el nombre a
 flutter_stable/bin/
 flutterstable
. En realidad, podemos darle cualquier nombre. Usaremos este nombre en lugar del
 flutter
comando, como
 flutterstable --version
.

Ahora ejecuta

 nano ~/.bash_profile
y agregue la ruta de la nueva versión. En mi caso se ve así (agregué la segunda fila):

 export PATH="$PATH:/Users/user/flutter/bin"
export PATH="$PATH:/Users/user/flutter_stable/bin"

Guarde, salga y reinicie el terminal.

Verifica si la ruta es correcta con el comando

 which flutterstable
. Debe dar algo como esto:
 /Users/user/flutter_stable/bin/flutterstable
.

Ahora el

 flutterstable --version
y
 flutter --version
los comandos deben dar versiones diferentes.

código de estudio visual

Cada proyecto puede usar una versión específica de Flutter. Abra la configuración de Visual Studio Code (

 Cmd+,
) y busca ' flutter sdk paths '. Seleccione ' Dart & Flutter ' en el menú de la izquierda, haga clic en ' Agregar elemento ' y agregue las rutas. En mi caso el resultado se ve así:

Reinicie el código de Visual Studio. Ahora, en la esquina inferior derecha, podemos seleccionar la versión flutter:

Como resultado, tenemos dos versiones diferentes de Flutter y podemos usar diferentes versiones para diferentes proyectos.